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Introduction

What Is in This Document

This document describes the new and changed features in Cognos Series 7 Version 4, as well as 
some new features from the maintenance releases of Series 7 Version 3. 

The structure is as follows:
• For a listing of enhancements by Cognos products and components, see "Cross Reference by 

Product and Component" (p. 9).
• "Superior Analysis" (p. 13) and "Superior Visualizations" (p. 15) describe features that help 

you analyze data more effectively.
• "Sophisticated Reporting" (p. 21) describes features that enhance the way you report 

information.
• "Comprehensive Information Delivery" (p. 23) describes features that improve the 

communication of information.
• "Complete Enterprise Management" (p. 27) describes features that are of most interest to 

system administrators.
• "Feature Changes" (p. 33) describes features that existed previously but have changed.
• "New Features for Series 7 Version 3 MR1, MR2, and MR3" (p. 43) describes maintenance 

release updates you may have missed if you did not install these interim releases.

What You Need to Know to Use This Book Effectively 

You should be familiar with the features and functionality of the Series 7 products.

For more information about using this product, visit the Cognos Global Customer Services Web 
site (http://support.cognos.com). For information about education and training, click the Training 
link from this site. 

Our documentation includes user guides, tutorial guides, reference books, and other materials to 
meet the needs of our varied audience. 

Online Help
All information is available in online help. Online help is available from the help button in a Web 
browser, or the Help menu and help button in Windows products. You can also download the 
online help from the Cognos Global Customer Services Web site (http://support.cognos.com).

Books for Printing
The information in each online help system is available in online book format (PDF). However, 
the information from a given help system may be divided into more than one online book. Use 
online books when you want to print a document or when you want to search the whole 
document. 

You can print selected pages, a section, or the whole book. Cognos grants you a non-exclusive, 
non-transferable license to use, copy, and reproduce the copyright materials, in printed or 
electronic format, solely for the purpose of providing internal training on, operating, and 
maintaining the Cognos software. 

You can also read the product readme files and the installation guides directly from Cognos 
product CDs.
New Features Guide  7
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Chapter 1: Cross Reference by Product and 
Component

This version of Series 7 delivers new and changed functionality into many products and 
components. In the following sections, you can view a list of the new features added to the 
products and components you are using, as well as changes to existing features. 

For information about features no longer supported in this version or after this version, see the 
Series 7 Version 4 Readme.

PowerPlay

PowerPlay Enterprise Server/PowerPlay Web
PowerPlay Enterprise Server/PowerPlay Web has the following new and changed features:

"Adding Statistical Calculations" (p. 14)

"Adding Statistical Lines to Charts" (p. 14)

"Changes to Dynamic Custom Exception Highlighting" (p. 42) (changed feature) 

"Changes to Enable Creating PowerPlay Agents in a New Browser Window" (p. 41) (changed 
feature)

"Charting for Multiple Measures" (p. 14)

"Controlling Audit File Size for PowerPlay Web" (p. 31)

"Customizing the Format of PowerPlay Agent Attachments" (p. 23)

"Exporting with High-fidelity to PDF" (p. 13)

"Formatting Charts" (p. 13)

"Moving Calculations Within a CrossTab" (p. 13)

"Setting the PowerPlay Enterprise Server Recycle Time" (p. 28)

"Suppressing Values Other than Zero" (p. 13)

PowerPlay for Windows
PowerPlay for Windows has the following new and changed features:

"Changes to Configuration Manager Setting to Control Memory" (p. 41) (changed feature)

"Changes to Dynamic Custom Exception Highlighting" (p. 42) (changed feature)

"Changes to Excel Export Support" (p. 41) (changed feature)

"Changes to Formatting When Exporting to Excel" (p. 41) (changed feature)

"Excluding Null or Missing Values from Time State Rollups in PowerPlay Reports" (p. 14)

"Exporting Layers to Excel" (p. 24)

Transformer
Transformer has the following new and changed features:

"Excluding Null or Missing Values from Time State Rollups in PowerPlay Reports" (p. 14)
New Features Guide  9
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"Using External Measures When Building Time Based Partitioned Cubes" (p. 27)

Impromptu

Impromptu Web Reports
Impromptu Web Reports has the following new and changed features:

"Assigning Dependency Based on Completion of Reports Associated with an Event" (p. 28)

"Automatic Cleanup of Report Data" (p. 29)

"Changes to Behavior of Browser Back Button When Viewing Reports" (p. 40) (changed feature) 

"Changes to start-iwr Script" (p. 40) (changed feature) 

"Controlling Reports that Exceed Governor Settings" (p. 28)

"Emailing Impromptu Web Reports in HTML format" (p. 23)

"Exporting Information About Scheduled Reports" (p. 28)

"Load Balancing for Request Processing" (p. 28)

"Logging Impromptu Web Reports Cleanup Actions" (p. 30)

"Notifying When Reports Associated with an Event are Complete" (p. 28)

"Preventing Direct Execution of Reports" (p. 27)

"Simplifying Delivery of Impromptu Web Reports to Multiple Users" (p. 23)

"SQL Logging for Individual Impromptu Web Reports" (p. 31)

Impromptu
Impromptu has the following new and changed features:

"Changes to Default Date-Time Formats" (p. 34) (changed feature) 

"Changes to Impromptu Chart Formatting" (p. 35) (changed feature) 

"Changes to Text and Marker Styles After Upgrading" (p. 35) (changed feature)

"Enhancing Charts" (p. 21)

"Entering Multiple Values in Type-in Prompts" (p. 21)

"Exporting a Form Frame within a List Frame to Excel" (p. 24)

"Exporting Header and Footer Images to Excel" (p. 24)

"Improved Catalog Security" (p. 30)

"Improved Exporting to CSV" (p. 24)

"Using Select All in Picklist Prompts" (p. 21)

Cognos Visualizer

Cognos Visualizer (Windows Authoring)
Visualizer Authoring has the following new and changed features:

"Aligning and Resizing Multiple Panels" (p. 17)

"Changing Chart Types, Dimensions and Measures" (p. 16)

"Customizing a Statistical Control Limits Chart" (p. 17)

"Default Maps With Up-to-date Geopolitical Boundaries" (p. 18)
10  Cognos Series 7 Version 4    



Chapter 1: Cross Reference by Product and Component
 

"Defining and Applying Standards for Fonts" (p. 17)

"Describing Panel Actions that Launch URLs" (p. 16)

"Changes to Drilling On Alternate Drill Paths" (p. 42) (changed feature) 

"Changes to Filter Settings on Chart Axes, Legends and Maps" (p. 42) (changed feature) 

"Changes to Scene Control in the Web Viewer" (p. 42) (changed feature) 

"Previewing Scene Layout" (p. 16)

"Specifying Default Directory Locations" (p. 18)

"Suppressing Zeros on Dimensional Data Sources" (p. 15)

"Synchronizing Maps and Charts for Drilling" (p. 16)

"Using MapInfo MapX 5.0 Maps" (p. 18)

"Viewing and Drilling Through to Actual Values in Scatter Plot Charts with Binned Data" (p. 15)

Cognos Visualizer Server and Server Administration
Cognos Visualizer Server and Server Administration have the following new and changed features:

"Auditing the Use of Visualizations" (p. 30)

"Better Searching for Cognos Visualizer Data Sources" (p. 29)

"Changes to Error Logging" (p. 42) (changed feature) 

Cognos Web Services
Cognos Web Services has the following new and changed features:

"New Functionality in Cognos Web Services API" (p. 24) 

NoticeCast
NoticeCast has the following new and changed features:

"Emailing Impromptu Web Reports in HTML format" (p. 23)

"Broader Agent Conditions" (p. 23)

"Changes to Enable Creating PowerPlay Agents in a New Browser Window" (p. 41) (changed 
Feature)

"Customizing the Format of PowerPlay Agent Attachments" (p. 23)

"Notifying When Reports Associated with an Event are Complete" (p. 28)

"Simplifying Delivery of Impromptu Web Reports to Multiple Users" (p. 23)

Shared Components

Access Manager
Access Manager has the following new and changed features:

"Stricter Basic Signon Password Management" (p. 30)

Upfront
Upfront has the following new and changed features:

"Using a Command Line to Upload Multiple Files to Upfront" (p. 25)
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Installation and Upgrade
Cognos Series 7 Version 4 includes the following new additions and changes:

"Changes to Build Numbering for Easier Identification of Releases" (p. 33) (changed feature)

"Change to cmplst.txt Build Identifiers for Initial Release of 7.4" (p. 33) (changed feature)

"Change to Enable Installing ObjectStore As a Non-Root User" (p. 34) (changed feature)

"Support for Firefox 1.5" (p. 31)

"Support for Microsoft SQL Server 2005" (p. 31)

"Support for Sybase Adaptive Server Enterprise 15" (p. 31)

"Upgrading from Previous Versions of Series 7" (p. 27)

"Upgrading and Migrating to Cognos 8" (p. 27)
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Chapter 2: Superior Analysis

Report authors and administrators responsible for creating and distributing PowerPlay reports, 
and users performing online analysis in Windows or on the Web, can take advantage of a number 
of product enhancements.

Enhanced User Experience on the Web

Exporting with High-fidelity to PDF
You can export a report to PDF from PowerPlay Web with high-fidelity printable output. This 
means the output produced appears as it does in your HTML-based report, accurately reflecting 
the colors and shading, font, and title formats. This gives you more control over the presentation 
of your analysis, including pagination, word wrapping, and fitting columns, rows, or charts to a 
page. You can now also include the status line in the PDF output. This functionality is available 
only from the enhanced UI. 

Administrators can enable or disable these additional options for a cube.

For more information, see "Export Data in PDF Format" in the PowerPlay Web User Guide.

Moving Calculations Within a CrossTab
You can now drag calculations to any location on an axis in PowerPlay Web reports, using the 
enhanced UI. You can also lock the calculation at the top or very left of the crosstab. When 
calculations are moved, they remain fixed in the position you specified as long as you continue 
exploring within the same dimension in the crosstab.

For more information, see "Move Calculations" in the PowerPlay Web User Guide.

Formatting Charts
To make charts visually easier to understand and communicate to others, you can now customize 
a wide variety of chart format options in the Enhanced UI of PowerPlay Web. For example, you 
can format colors, patterns, and gradients for bars, use a palette to format colors and markers for 
lines, and customize font properties on labels. You can also set scaling factors on axes, customize 
chart backgrounds, or change the format of a pie chart into a ring chart.

In the Generic UI of PowerPlay Web you can see charts that have been created and formatted, but 
you cannot modify or create them.

For more information, see "Format Data" in the PowerPlay Web User Guide.

Suppressing Values Other than Zero
In PowerPlay Web, you can now suppress any combination of zero values, missing values, 
overflow values or divide-by-zero (/0) values. The settings for these options are included in the 
Explain text, and are saved with the report. 

Administrators can enable or disable these options for a cube.

For more information, see "Suppress Values" in the PowerPlay Web User Guide.
New Features Guide  13
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Excluding Null or Missing Values from Time State Rollups in PowerPlay 
Reports

If you need to exclude null or missing values from your PowerPlay reports, for average or 
weighted average time state measures, you can now do so in Transformer.  

For more information about using the Transformer (Windows) interface to exclude null or missing 
values from your PowerPlay reports, see "Ignore Null and Missing Values in Specified Time State 
Rollups" in the Step-by-Step Transformer help. 

You can also set the IgnoreMissingValue property using Model Definition Language (MDL) or 
OLE automation. For more information, see the Transformer MDL Reference and the 
Transformer Macro Reference Guide. 

Advanced Analysis

Charting for Multiple Measures
Two new powerful chart types are available in the Enhanced UI of PowerPlay Web. Scatter charts 
and correlation charts enable you to perform analysis against multiple measures. 

A scatter chart plots two measures to find a correlation between them. A correlation chart is a bar 
chart overlaid with a line chart, which allows you to show two different measures using a shared 
X-axis and two Y-axes. The left-hand and right-hand Y-axes can each have a different scale, 
enabling you to visually compare dissimilar measures. 

In the Generic UI of PowerPlay Web, you can see these new charts but you cannot create or 
modify them.

For more information, see "Choose a Display" in the PowerPlay Web User Guide.

Adding Statistical Lines to Charts
To further understand the distribution of your data in the PowerPlay Web Enhanced UI, you can 
add statistical lines to your charts. You can show the mean (average) and standard deviation as 
lines on the chart. You can also set your own custom threshold value to compare data against.

In the Generic UI of PowerPlay Web, you can see these formatted charts but you cannot create or 
modify them.

For more information, see "Show Statistical Lines" in the PowerPlay Web User Guide.

Adding Statistical Calculations
If your use of data includes statistical analysis, you can now create these calculations in PowerPlay 
Web. You can add calculations for the mean, median, minimum, and maximum values. You can 
also use percentiles to show the percent distribution of data. 

For more information, see "Add Calculations" in the PowerPlay Web User Guide.
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Chapter 3: Superior Visualizations

Visualization authors and administrators responsible for creating and distributing visualizations, 
and users performing online analysis in Windows or on the Web, can take advantage of a number 
of product enhancements.

Enhanced User Experience on the Web

Suppressing Zeros on Dimensional Data Sources
You can use Cognos Visualizer to suppress data from dimensional data sources such as 
PowerCubes. The suppression is maintained when users view the visualization in Cognos 
Visualizer Web Edition Client or Cognos Visualizer Web Edition Viewer. You can suppress any 
combination of zero values, missing values, overflow values or divide-by-zero (/0) values. 

If charts are synchronized and share an axis while suppression is enabled, then both charts will use 
the suppression. If overlay charts are used, the same suppression must be enabled on the 
dimension axes of both charts.

You cannot suppress data from relational or spreadsheet-based data sources.

For more information, see "Suppress Zeros on Dimensional Data Sources" in the Cognos 
Visualizer User Guide. 

Viewing and Drilling Through to Actual Values in Scatter Plot Charts with 
Binned Data

To help users understand the underlying data that may be driving a correlation between measures, 
you can use Cognos Visualizer to enable users to view or drill through to the actual data values 
that are summarized, or binned, into a data point on a scatter plot chart.

A scatter plot chart is a statistical chart used to plot two continuous (non-categorical) measures in 
an attempt to find a correlation between them. Scatter charts do not roll up values, and so each 
data item has a point on the chart. When the cluster of data items trend towards a line, this 
indicates a correlation between the measures. To reduce the number of points on a chart, binning 
can be used. Binning divides the area of the chart into an equal number of slots, or bins. All data 
items that fall into a bin are represented by a single point. If a particular bin does not have any 
data items in it, the bin will not contain a plotted point. 

To help understand the actual data values of any point, such as an outlier, you can view or drill 
through to see the actual value. When viewing is enabled, if a user requests to view the actual 
values for a binned data point, they will be prompted to confirm the action if the request would 
retrieve a large volume of data. Large data volumes may cause a delay and additional processing 
demands on the system. To view actual data values for a binned data point, the underlying data 
must be retrievable using the SQL definition in the associated data source (IQD file). The Explain 
window shows the point-specific values in the data grid. When a scatter plot chart does not use 
bins, the sole record for the individual point is shown.

When a user drills through to actual values, filters are generated so that the data items shown in 
the target report are only those that contribute values to a bin.

For more information, see "View and Drill Through to Actual Values in Scatter Plot Charts with 
Binned Data" in the Cognos Visualizer User Guide.
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Synchronizing Maps and Charts for Drilling
To help users understand the relationship between a location on a map and the same information 
in a chart, you can use Cognos Visualizer to synchronize the map and the chart data.

Map-chart drill synchronization works in both directions. When you drill on a map, the location 
dimension for the chart's data source is searched for a matching category, and the chart drills to 
the same category. When you drill on the location dimension of a chart, the location dimension for 
the map drills to the same location. 

Synchronization between a map and a chart requires a correspondence between map locations 
and the location categories in the chart data source. All category-based charts with at least one 
location dimension can be synchronized with a map on the same sheet provided
• they use the same data source
• they use the same dimension for the selected axis in the chart as the point or region on the 

map
• the chart and map are both set to the same location level

Maps with a drill hierarchy containing the same location more than once cannot be synchronized 
because of the ambiguity of having duplicate locations. For the same reason, charts that use a data 
source in which a location category appears more than once in the primary drill path cannot be 
synchronized.

For more information, see "Synchronize Maps and Charts for Drilling" in the Cognos Visualizer 
User Guide.

Describing Panel Actions that Launch URLs
You can help users understand what will happen when they select a panel that launches a URL. In 
Cognos Visualizer, you can define tooltips for panel actions that explain what happens when a 
user selects the panel in the Web Edition Client or Web Edition Viewer. If no description is 
defined, the tooltip shows the URL.

For more information, see "Describe Panel Actions that Launch URLs" in the Cognos Visualizer 
User Guide.

Advanced Visualizations

Changing Chart Types, Dimensions and Measures
You can now use Cognos Visualizer to change from one chart type to another instantly. You can 
also change the dimensions or measures in an existing chart. You do not have to delete and 
recreate the chart to make these changes.

Some chart types will transform automatically from one type to another, while others will prompt 
you to supply additional information required for the new chart type. Not all chart types can be 
changed into all other chart types, particularly if there are multiple charts on a single panel.

When changing from one chart to another, chart and axis properties are preserved, such as names, 
palettes, labels, feelers, values and scroll, grid and format settings. For numeric axes, numeric 
precision, scales, intervals, decimals, format, location, and waterline settings are preserved.

For more information, see "Change Chart Dimensions and Measures" in the Cognos Visualizer 
User Guide.

Previewing Scene Layout
You can preview the layout of your scenes directly in Cognos Visualizer, without having to publish 
the visualization. This allows you to see how multiple scenes will be displayed in the Web Edition 
Viewer. You can further imitate the user’s environment by setting the dimensions of the screen area 
to those you expect a typical viewer to use in their browser.
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For more information, see "Preview and Set Scene Layout for Web Edition Viewer" in the Cognos 
Visualizer User Guide.

Aligning and Resizing Multiple Panels
To improve ease of use, you can now use Cognos Visualizer to align and resize multiple panels, 
similar to how you align and size objects in other drawing tools. You can align panels to the top, 
bottom, centre, left, right, and middle, with or without panel grouping. You can also resize all 
selected panels to the same size.

For more information, see "Align and Resize Multiple Panels" in the Cognos Visualizer User 
Guide.

Defining and Applying Standards for Fonts
Cognos Visualizer also allows you to define default font settings. You can define a default size, 
style, color, and font face. This allows you to set a standard for text on newly created charts using 
Cognos Visualizer. This can be done for the following objects:
• axis labels
• axis tick labels
• table chart column headers
• row headers and cell text
• crosstab dimension headers
• dimension items and cell text
• waterline labels
• chart values
• panel legends and text
• value charts

You can apply your defaults to existing visualizations by using Apply to All, or you can restore all 
text to the default font settings. 

For more information, see "Define and Apply Standards for Fonts" in the Cognos Visualizer User 
Guide.

Customizing a Statistical Control Limits Chart
A control limits chart is typically used in statistical process control, sometimes associated with Six 
Sigma quality initiatives. These initiatives are designed to eliminate defects in processes, such as 
manufacturing or logistics. A control limits chart has a time-based category and calculated upper 
and lower control limits. For example, a control limits chart could show the number of defects on 
an assembly line over time, with the upper and lower control limits indicating whether production 
quality is within the expected tolerance. 

To more finely adapt a control limits chart to the needs of different industries and quality 
initiatives, Cognos Visualizer now allows you to define points in time where changes to a process 
were implemented to see the effects of those changes. You do this by having upper and lower 
control limits calculated and adding separate waterlines for the periods between those points in 
time. In the Web Edition Client and Web Edition Viewer, users will be able to clearly distinguish 
the process change points. However, Web Viewer users cannot modify the waterlines. Web Client 
users can control the display of waterlines.

Standard Formula
The standard formula for calculating upper and lower control limits is as follows:
• Mean + n standard deviations, where n is any number the author enters.

This formula allows the author to create control limits following Six Sigma practices, where +/- 3 
sigma (or +/- 1 sigma or +/- 2 sigma) creates commonly used upper and lower limits.
New Features Guide  17



Chapter 3: Superior Visualizations 
 

Alternate Formula
You can choose to use an alternate formula for calculating upper and lower control limits. The 
alternate formula is considered by some experts to be approximate and therefore more suitable 
when the available data points are only a partial sample of all the actual data. This formula is as 
follows:
• Mean + ‘n’ * average moving range, where 

Mean is the same value used for the calculation of other waterlines
n is any number the author enters
the average moving range is the average of the control limit chart’s lower values. 

Mathematically, this formula is as follows:
• X-bar + n * mR-bar, where

• X-bar = ∑  Xt / k
• mR-bar = ∑  | Xt – Xt-1| / (k-1), where

k = number of data points
n = user-defined constant

The ‘n’ value is specified by the author, but defaults to a value of 2.66. The default value 
indicates a confidence level of 99% when using this formula. 

A control limit chart typically shows a pair of related charts, the upper chart being the individual 
values and the lower being the moving range. You can choose to hide or show either, but not both 
of these charts, in Cognos Visualizer. When hidden (or shown) by an author, a chart cannot be 
subsequently shown (or hidden) by a user of the Web Client or Web Viewer.

For more information, see "Customize a Statistical Control Limits Chart" in the Cognos 
Visualizer User Guide.

Default Maps With Up-to-date Geopolitical Boundaries
The default maps in Cognos Visualizer now include the latest geopolitical boundaries, such as 
level 1 and 2 European Nomenclature of Territorial Units for Statistics (NUTS) boundaries. Some 
country names have been updated to reflect changes, such as in the Balkans and Africa, and a 
larger set of U.S. zip codes is provided. 

You can create new visualizations using the new maps or recreate existing visualizations to use the 
new maps. You can also continue using the existing set of maps provided with earlier versions of 
Cognos Visualizer, as well as your existing custom maps. 

For more information, see the Cognos Visualizer Administrator’s Guide.

Using MapInfo MapX 5.0 Maps
You can include your own custom maps based on maps created with the latest version of 
MapInfo's MapX, version 5.0. You can also continue to use custom maps created with earlier 
versions of MapInfo MapX.

Specifying Default Directory Locations
For improved ease of use, you can now specify default directories for visualizations and data 
sources in Cognos Visualizer. If a directory entry is empty, Cognos Visualizer remembers the last 
visited directory. 

The default directory for visualizations is used when
• opening a visualization 
• saving a visualization 
• importing visualization objects (sheets, scenes, panels, or filters)

The default directory for visualizations does not apply to the File, Save as HTML command. 

The default directory for data sources is used when
• selecting a data source
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• exporting to CSV

When specifying a default data source directory, all data sources are included, with the exception 
of remote cubes. You must use the Choose a Remote Cube feature when selecting a remote cube as 
a data source.

For more information, see "Specify Default Directory Locations"in the Cognos Visualizer User 
Guide.
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Chapter 4: Sophisticated Reporting

Impromptu report authors and catalog administrators, Windows and Web-based report users, and 
PowerPrompts developers can all benefit from the enhancements added to the query and reporting 
components.

Enhanced User Experience on the Web

Using Select All in Picklist Prompts
To improve the ease-of-use for report consumers, you can use Impromptu to create reports that 
offer consumers the option to Select All prompt values. This is easier than selecting all of the 
prompt values individually for a multi-select prompt, and will save users time. 

For more information, see "Add the Select All Option to Picklist Prompts" in Mastering 
Impromptu Reports.

Entering Multiple Values in Type-in Prompts
To improve productivity of report consumers, you can use Impromptu to create reports where the 
consumer can enter multiple values as a response to a type-in prompt. This is especially powerful 
as these values can be used with an IN clause in a filter to search for multiple values.

For more information, see "Create a Type-in Prompt With the In Operator that Accepts Multiple 
Values" in Mastering Impromptu Reports.

Enhanced Report Presentation

Enhancing Charts
Impromptu’s charting user interface has been improved to enable a vast array of new capabilities. 
With about 100 new formatting options, you can control the presentation of almost all chart 
objects, from sizes and shapes to locations, fonts, colors, depth, explosions, patterns, 
backgrounds, labels, legends, axes, markers, and more. When you upgrade your existing 
Impromptu reports with charts, you may notice that some chart properties have new names.

One of the newly-available charts is a correlation chart. This is a bar chart overlaid with a line 
chart, which allows you to show two different measures with a shared X-axis and two Y-axes. The 
left and right Y-axes can each have a different scale, enabling you to visually correlate dissimilar 
measures. For example, you can show products on the shared X-axis, with revenue on the 
right-hand Y-axis and units-sold on the left-hand Y-axis, and visually compare the relationship 
between revenue and units-sold for each product.

You can also display a trend line with a regression type of linear, logarithmic, polynomial, 
exponential, or moving average. Note that these are all trend lines, and do not provide forecasting 
capabilities. You can show titles, subtitles and include footnotes. You can also control grids and 
scales including the use of a logarithmic scale.

In addition, the way you define the dimension layout for charts has changed. Menu items that 
previously listed charts such as 2D Area, 3D pie, 3D Bar now identify the chart type such as area, 
pie, or bar, without specifying the dimensions. You now choose a chart first and then customize 
the dimensions using the properties. 
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For more information, see the chapter "Create and Customize a Chart" in the Impromptu User 
Reference online book and the Impromptu online help.
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Chapter 5: Comprehensive Information Delivery

Administrators seeking to implement more open systems, with a broader range of publishing and 
notification capabilities, will welcome several enhancements added for this release.

Broader Notification Capabilities

Simplifying Delivery of Impromptu Web Reports to Multiple Users
You can send Impromptu Web Reports to many users more easily using addressing based on user 
class membership. The benefit of user class-based addressing is that you no longer have to add or 
delete individual users, although you can still do this. User class membership is always up-to-date, 
and reports are delivered to only the current members of the specified user classes.

For more information, see "Add A User Class to an Email List' in the Cognos Web Portal User 
Guide.

Emailing Impromptu Web Reports in HTML format
In addition to emailing attachments as PDF, Excel, delimited text, and XML, you can now send 
reports as email attachments in HTML Web Archive format. This feature attaches the output as a 
Multipurpose Internet Mail Extension HTML (MHTML) format with a .mht file extension, and is 
viewable only in Internet Explorer.

For more information, see "Generate a Report in Different Formats" in the Cognos Web Portal 
User Guide.

Customizing the Format of PowerPlay Agent Attachments
You can specify format settings, such as page orientation (portrait or landscape), for PDF 
attachments delivered by PowerPlay Agents. When creating an alert, you can override the default 
Print settings defined in PowerPlay Administrator to specify a format that better suits the layout of 
that particular report.

For more information, see "Create an Agent" in the PowerPlay Web User Guide.

Broader Agent Conditions 
To increase the power and sophistication of your agent conditions, you can now use agents to 
check for data that is NULL, is not NULL, or for data that does not fall between a specified range 
of values.

For information, see "Create an Agent" in the PowerPlay Web User Guide, and "Add or Modify a 
Rule" in the Cognos Web Portal User Guide .
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Extended Openness

Exporting Layers to Excel
To improve fidelity between your PowerPlay report and Microsoft Excel when you Save As Excel 
in PowerPlay Windows, a Microsoft Excel worksheet is now automatically created for each layer 
in your report. Each worksheet is named after the layer, suffixed by a sequential numeric 
identifier. For example, the names might look like Americas_1, Asia_Pacific_2, Europe_3, and so 
on. If you have no layers, only a single worksheet is created. 

This feature is available with Excel 2002 or higher. Excel 2002 is now the default version used. If 
you want to use an older version of Excel, you can configure PowerPlay to use an older version. 
For information, see "Changes to Excel Export Support" (p. 41).

For more information, see "Distribute Reports" in the PowerPlay User Guide.

Exporting Header and Footer Images to Excel
To improve fidelity between your Impromptu report and Microsoft Excel outputs, images in 
Impromptu page headers or footers, such as corporate logos, are now included in the 
corresponding Excel page headers or footers. This occurs when you Save As Excel with Format, or 
create an Excel output in Impromptu Web Reports, and you specify an output format of Excel 
2002 or higher. 

For more information, see "Export a Report to Excel with Images in the Header and Footer" in 
Mastering Impromptu Reports.

Exporting a Form Frame within a List Frame to Excel
Microsoft Excel outputs from Impromptu reports also more closely resemble their source in that a 
list frame that exists within a form frame now displays the data from the list frame within your 
Excel worksheet. This occurs when you Save As Excel with Format, or create an Excel output in 
Impromptu Web Reports, and you specify an output format of Excel 2002 or higher. 

For more information, see "Export a Form Frame within a List Frame To Excel" in Mastering 
Impromptu Reports.

Improved Exporting to CSV 
When you Save As delimited ASCII in Impromptu or Impromptu Web Reports, you can now 
control whether leading zeroes in text fields are retained when saving the report as delimited 
ASCII text (.csv). For example, in a product number or postal code, you can use the Mark text 
fields for import into Microsoft Excel setting to ensure the leading zeroes are preserved when 
saving the report as Delimited ASCII (.csv). In addition, you can choose to have null or missing 
values in numeric fields exported as zeroes when saving the report as Delimited ASCII (.csv).  

For more information, see the topics "Export a Text Field with Leading Zeroes to Excel" and 
"Export a Numeric Field with Null or Missing Values to Excel" in Mastering Impromptu Reports.

New Functionality in Cognos Web Services API 
CWS APIs include the latest features available in the BI servers. Therefore you can use CWS to 
create applications that make use of the most up-to-date functionality available in BI. For 
PowerPlay, this includes the new chart types, zero suppression options, and the new statistical 
calculations. 

For more information, see the Cognos Web Services SDK API Reference. 
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Flexible Publishing

Using a Command Line to Upload Multiple Files to Upfront 
In Upfront, users can upload static files to their NewsBoxes one at a time. To upload multiple 
files, you can now use a command line utility. Using FMCmnd, you can script the upload of 
multiple files, and use wildcards and parameters. You can also upload the contents of an entire 
directory. Newsboxes can be automatically created for the uploaded files. The upload command 
script can be run interactively, or it can be scheduled. 

For more information, see "Upfront Automation Interfaces" in the Upfront Developer Guide.
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Chapter 6: Complete Enterprise Management

This release of Series 7 includes continuing improvements to further help you implement and 
manage a secure, scalable, easily localized business intelligence application. 

Application Upgrade

Upgrading from Previous Versions of Series 7
You can upgrade to Series 7 Version 4 (7.4) from Version 3 (7.3), or directly from Version 2 (7.1). 
It is not necessary to upgrade from Version 2 to Version 3, and then to Version 4.

Upgrading and Migrating to Cognos 8
You can migrate or upgrade certain types of content from Series 7 Version 2 (7.1) or Version 3 
(7.3) to Cognos 8. As of this Initial Release, migration or upgrade tools from Series 7 Version 4 to 
Cognos 8 are not yet available. For up-to-date information about availability of the migration and 
upgrade tools see the Cognos Global Customer Services Web site (http://support.cognos.com).

For more information about migrating and upgrading to Cognos 8, see the Migration and 
Upgrade User Guide. 

Improved Administration and Data modeling

Using External Measures When Building Time Based Partitioned Cubes
You can now include externally rolled up measures in time-based partitioned (TBP) PowerCubes. 
This provides the same power and flexibility with externally rolled up measures as standard 
PowerCubes. 

For more information about time-based partitioning, see the Step-by-Step Transformer online 
help.

Preventing Direct Execution of Reports
As an administrator, you can now prevent end-users from running Impromptu Web Reports 
directly. This is particularly useful for reports that are intended only to produce a picklist, dataset, 
or HotFile for another report. It is also useful for reports intended only to be run as a 
drill-through target from another report or from a cube. Such reports usually have filters limiting 
the query to a subset of the data. With this new feature, users are prevented from unnecessarily 
running reports.

For more information, see "Prevent Users from Running a Report" in the Cognos Web Portal 
User Guide.
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Controlling Reports that Exceed Governor Settings
As an administrator, you can now control the behavior of reports that exceed governor settings. 
When a report exceeds these settings, users receive a message that the volume of data or 
processing time has exceeded allowable limits. You can control whether the report will be empty 
or contain partial data up to the point where the governor was exceeded. You can also delegate 
control to users by allowing them to define the data behavior for each report.

For information about enabling and disabling governors in Impromptu Web Reports - Report 
Administration, see "Enable and Disable Governors" in the Impromptu Web Reports 
Administrator Guide.

For information about enabling and disabling governors in Upfront, see the Cognos Web Portal 
User Guide.

Notifying When Reports Associated with an Event are Complete
You can now write a script to notify you or take an action when all the reports associated with an 
event have completed. This allows you to create applications that can better link actions to the 
completion of these events.

For more information, see "Notify when a Report Associated with an Event is Complete" in the 
Impromptu Web Reports Administrator Guide.

Assigning Dependency Based on Completion of Reports Associated with an 
Event

You can now define an event that depends on the completion of the reports associated with 
another event. This allows you to create an event that will run only when another event is 
complete. This new feature simplifies administration and allows more flexibility for defining 
dependencies. 

For more information, see "Assign Dependency Based on Completion of Reports Associated with 
an Event" in the Impromptu Web Reports Administrator Guide.

Exporting Information About Scheduled Reports
In addition to reviewing scheduled report executions using Impromptu Web Reports Server 
Administration, you can now export a list of scheduled report executions, for printing or for 
further analysis.

For more information, see "Using Server Administration" in the Impromptu Web Reports 
Administrator Guide.

Improved Scalability and Performance

Setting the PowerPlay Enterprise Server Recycle Time
To maximize the stability of heavily loaded systems with long intervals between scheduled 
restarts, you can set the amount of time that a PowerPlay Enterprise Server process is allowed to 
run before it is recycled. A process is recycled after it has run for a set amount of time, unless it is 
currently serving a request or has remote connections.

For more information, see "Process Control" in the PowerPlay Enterprise Server Guide.

Load Balancing for Request Processing
To better distribute requests across a larger number of Impromptu Web Reports servers, 
administrators can now specify a weighting factor proportionate to the power and capacity of the 
computer. This load distribution can optimize requests such as view operations and administrative 
commands. 
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Users who view previously saved reports may particularly benefit. For example, on heavily loaded 
systems, where two or more servers are configured for request processing but each has a different 
processing capacity, users should see an improvement in performance. 

This feature does not distribute report processing. This is already managed by configuring queues 
on different servers.

For more information, see "Set Load Balancing Weights for Servers" in the Impromptu Web 
Reports Administrator Guide, and the topic "Specify Weighting Factors for Distributing Requests 
Across Servers" in the Cognos Server Group Settings section of the Configuration Manager User 
Guide.

Automatic Cleanup of Report Data
Administrators have a new cleanup tool for managing transient data from reports that have run. 
The new cleanup procedure deletes all data more than a day old from the Impromptu Web 
Reports dispatcher. This data is transient in nature, and is no longer needed once it has been used. 
The data includes the following: 
• URLs used to view reports that have just been run 
• Drill through filter information, no longer required after the drill through is run.
• URLs stored while the user logs on again after a session has ended.

This cleanup utility runs separately from the cleanup that administrators can set using the Server 
Administration tool, to ensure that it runs regularly. The cleanup routine runs every hour, and 
report data is deleted when it is more than 24 hours old.

The cleanup routine frequency is set through Configuration Manager. Changing the cleanup 
routine frequency to run more often may be desirable if you run a large number of reports on a 
regular basis. This ensures that irrelevant data is cleared from memory and frees up more of the 
system resources for the dispatcher process.

Note that negative intervals and intervals longer than one month are not valid and will cause an 
error message when validating or applying the configuration settings. You can still apply such an 
interval, but the out-of-range value will cause Impromptu Web Reports to use the default.  

For more information, see "Cognos Impromptu Web Reports Settings" in the Configuration 
Manager User Guide.

Improved Deployment

Better Searching for Cognos Visualizer Data Sources
You can now set up a more flexible directory structure for your data sources, independent of your 
environment. There is a new fourth run-time method that searches and locates data sources, in 
addition to the three existing methods. 

The methods now search: 
1. in the path specified in the visualization file (.viz)
2. in the directory containing the visualization file (.viz)
3. in the directories specified by the VIZ_DATA_SOURCES environment variable
4. in the path specified in the visualization, pre-pended with the directory location specified by 

the VIZ_DATA_SOURCES value 

This method uses a combination of the 1st and 3rd methods.

For example, consider the following scenario: 

A visualization uses C:/Test/Cognos/Viz/Cubes/cube.mdc and C:/Test/Cognos/Viz/IQDs/table.iqd 
as data sources. In the visualization data source properties, Cubes/cube.mdc and IQDs/table.iqd 
are specified. In addition, the author sets the VIZ_DATA_SOURCES variable to 
C:/Test/Cognos/Viz/.
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In this scenario, search methods 1, 2 and 3 fail to find the data sources (assuming the visualization 
is in neither of those data source directories), but method 4 successfully finds the data sources. 
This is because VIZ_DATA_SOURCES was pre-pended to the data source values in the 
visualization, creating the full paths C:/Test/Cognos/Viz/Cubes/cube.mdc and 
C:/Test/Cognos/Viz/IQDs/table.iqd.

For more information, see "Search for Cognos Visualizer Data Sources" in the Cognos Visualizer 
User Guide.

Logging Impromptu Web Reports Cleanup Actions 
To give you the most up-to-date picture of the status of your application, actions taken by the 
cleanup job are now logged automatically. These cleanups include such actions as deleting 
obsolete or orphaned report outputs. Administrators can use the log to easily see which objects 
were affected by any cleanup. 

For more information, see "Log Cleanup Actions" in the Impromptu Web Reports Administrator 
Guide.

Improved Security

Stricter Basic Signon Password Management
To meet stricter governance requirements in your IT environment, Access Manager administrators 
can now enforce Basic Signon password rules. For example, you can force the inclusion of upper 
case and lower case characters, numerals, and special characters. Administrators can also enable 
password history enforcement, to ensure that old passwords are not reused.

For more information, see "Set Password Properties for Users in a Namespace" in the Access 
Manager Administrator Guide.

Improved Catalog Security 
You can now lock a catalog to further restrict its access to the catalog Creator user class. This 
added security will prevent all members of the Creator User Class in the Access Manager 
namespace from accessing this catalog. This security is important where you have multiple 
catalogs, each with different users who are Creators, and all users are members of the Creator 
User Class in the same Access Manager namespace.

For more information, see the topics about locked catalogs in Mastering Impromptu Reports or 
the Impromptu Administration Guide. Information is also available from within the product using 
the Help buttons.

Improved Auditing

Auditing the Use of Visualizations
You can enable richer auditing on each Cognos Visualizer Web Edition server to capture more 
information about the visualizations that run on that server. The information captured includes 
the visualization accessed, the name of the user and their user class, as well as the timestamp, 
server name, and any actions performed. The auditing settings also now apply to all visualizations 
published to a Visualizer server. If you have multiple Cognos Visualizer Web Edition servers in a 
group, you can enable auditing on all servers in the group and concatenate the audit files together 
to get a complete picture of your visualization usage in one file. 

In previous releases, the audit log file was only created in the bin directory on Unix, and sent to 
the Event Viewer in Windows. Now a tab-delimited audit log file called vizwebaudit.log is created 
in the <installation_location>\cern\logs location.
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For more information, see "Audit a Visualization" in the Cognos Visualizer Web Edition 
Administrator’s Guide.

SQL Logging for Individual Impromptu Web Reports
In Upfront, you can now specify that the SQL executed by an individual Impromptu Web report is 
captured in a separate log file. These report-specific logs are independent of the general auditing 
information gathered because their purpose is to assist in meeting IT governance requirements, 
such as tracking who reported on which columns from which tables. An alternate use might be to 
temporarily use such logs to aid in problem resolution for reports.

For more information, see "Log SQL for a Report" in the Cognos Web Portal User Guide.

Controlling Audit File Size for PowerPlay Web 
PowerPlay Enterprise Server administrators now have better control of audit file sizes. 
Administrators can control the maximum size that an audit file can grow to before a new audit file 
is created. There is also a default value for the file size. This means you do not have to wait until 
the server is stopped and re-started for a new file to be created. It also means smaller files for the 
AuditFileProcessor to handle, so that loading the auditing data into a database is done in smaller 
chunks, which should make the load time shorter. 

When you upgrade an enterprise server application, the value for audit file continues to be 
unlimited, so that existing large files are not affected and new files are only created when the 
server is stopped and re-started. If you re-enable auditing, the file size value is set to the new 
default size for future files. This size can then be changed by the administrator.

Previously, a new audit file was created only when the PPES server was stopped and re-started.

For more information, see "Enable Auditing" in the PowerPlay Enterprise Server Guide.

Leverage Existing Infrastructure
The following updates to supported environments are available in Series 7 Version 4.

For more information about supported software environments, see the Cognos Global Customer 
Services Web site (http://support.cognos.com).

Support for Microsoft SQL Server 2005
Support has been added in Series 7 Version 4 for Microsoft SQL Server 2005.

Support for Sybase Adaptive Server Enterprise 15 
Sybase Adaptive Server Enterprise 15 is supported in Series 7 Version 4.

Support for Firefox 1.5 
Firefox version 1.5 is supported in Series 7 Version 4.
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Appendix A: Feature Changes

This chapter contains information about changes you will see in the behavior of existing Series 7 
features. The changes outlined have been added based on product feedback. 

Installation Changes

Change to cmplst.txt Build Identifiers for Initial Release of 7.4
In previous versions of Series 7, build identifiers for products and components used the qualifier 
’RTM’ for builds associated with the initial release of a new version. Maintenance Releases are 
identified by an MRn qualifier, where n is the maintenance release number. These build identifiers 
can be found in the cmplst.txt file, which exists in the installation_location/cern folder. You may 
need to refer to them when speaking with customer support or otherwise verifying a build 
number.

For example, the following text identifies a build of the initial release of Series 7 Version 3 (7.3):
Access Manager Administration=AM-win32-en-RTM-7.3.700.0.0 

This text,
Access Manager Administration=AM-win32-en-MR1-7.3.808.0.0 

identifies a build of Maintenance Release 1 (MR1) of Series 7 Version 3 (7.3).

Starting with Series 7 Version 4, the build identifier for the initial release is now INR.

For example, the following text identifies a build of the initial release of Series 7 Version 4 (7.4):
Access Manager Administration=AM-win32-en-INR-7.4.700.0.0 

As in previous versions, Maintenance Releases will continue to be identified by an MRn 
designation.

This change applies only to the Series 7 line of products.

Changes to Build Numbering for Easier Identification of Releases
As of Series 7 Version 4, it will be easier to identify which release of a version you have installed, 
using only the build number.

The Initial Release will have build numbers in the range 0-999. For example, in an About box, 
you will see a version number such as 7.4.700.0, or in the cmplst.txt file in the 
installation_location/cern folder you will see an entry such as, 
Access Manager Administration=AM-win32-en-INR-7.4.700.0.0.

Build 7.4.700 indicates that this is Series 7 Version 4, and since 700 is in the range 0-999, it is the 
Initial Release, as opposed to a Maintenance Release.

Maintenance Releases will us the following build numbers:
• Maintenance Release 1 (MR1) will have build numbers in the range 1000-1999.
• Maintenance Release 2 (MR2) will have build numbers in the range 2000-2999.
• Maintenance Release 3 (MR3) will have build numbers in the range 3000-3999.

All products and most components will follow this convention, but there are some exceptions, for 
components such as PPDS and UDA, which have no user interfaces. These low-level components 
will not follow the new numbering system.

This change applies only to the Series 7 line of products.
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Change to Enable Installing ObjectStore As a Non-Root User
Installing and configuring ObjectStore on UNIX using root privileges is the recommended option, 
however installing ObjectStore as a non-root user is also possible. The following conditions apply 
when you install ObjectStore as a non-root user:
• You limit the number of allowed permissions the ObjectStore server can use to access 

ObjectStore databases.
• You must manually start the ObjectStore cache manager process because it cannot start 

automatically.

For more information, see "Install ObjectStore" in the Solution Installation Guide.

Impromptu

Changes to Default Date-Time Formats
In Impromptu Series 7 Version 3, users received a list of suggested formats when formatting date, 
date-time, time and interval data. These were compatible with the en-us locale, but not always 
with locales in other countries. In Series 7 Version 4, the list of suggested formats more closely 
reflects the locale settings of the user, based on information obtained from cerlocale.xml.

The format changes include the following:
• Date-time formats that had shown tt-mmm  now suggest tt.mmm, using the separator read 

from the configuration file cerlocale.xml. 
• Date formats that had shown dd-mmm now suggest dd/mmm, using the separator from 

cerlocale.xml.
• Time formats that had shown hh:mm now suggest h:mm, dropping the leading zero in the 

format for single digit numbers. 

For example German users (de-de locale) will now see suggested Date formats that use dots to 
separate the components of dates, so tt/mm/jj becomes tt.mm.jj. 

Users in the United States (en-us locale) will now see suggested Time formats that omit the 
leading zero in front of single-digit hours, so that hh:mm am/pm becomes h:mm am/pm. In this case, 
half past eight in the evening changes from 08:30 pm to 8:30 pm. In addition, where Impromptu 
used to suggest the following date-time format,

M/d/yyyy hh:mm:ss am/pm, and dd-mmm 

it now suggests:

M/d/yyyy hh:mm am/pm (if cerlocale.xml uses a 12-hour clock), 

or

M/d/yyyy hh:mm (if cerlocale.xml uses a 24-hour clock. 

The new suggested formats appear in the Format and the Options dialog boxes in Impromptu 
User and Impromptu Administrator.

Notes: 
• This change only affects the list of suggested formats that are presented to report authors 

when they create or edit an Impromptu report. Existing reports will continue to show the 
same date-time formats that were used in earlier versions of Impromptu. 

• Report authors can specify any arbitrary date-time format by typing in the format string 
directly. This functionality was present in previous versions of Impromptu, and remains 
unchanged in this version.

• Customers can change the list of suggested formats by editing the cerlocale.xml file.
For information, see Appendix A of the Configuration Manager User Guide.

For more information, see the definition for General Format in the Impromptu glossary. The new 
defaults also appear in the product when you set data formatting.
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Changes to Text and Marker Styles After Upgrading
When you upgrade your reports from Impromptu Series 7 Version 3 to Series 7 Version 4, you will 
notice some changes to Impromptu charts. 

The word Wrap and Truncate options, available with previous versions of Impromptu, have been 
removed from the x-axis of a chart. Users can now modify the properties on the x-axis by 
changing the font style, size, and staggering labels, instead of using word wrapping and 
truncation. After the chart formatting is modified as part of an upgrade, the chart will show all 
the data. Consumers of Impromptu Web Reports will also notice this change.

If you used the Variant style marker in charts, you may notice changes to the markers following an 
upgrade from Series 7 Version 3 to Series 7 Version 4. To change the style markers back to a 
particular marker style, you can edit the report and use the Customize per data item dialog box to 
select the marker style you want.

For more information, see the Impromptu User Reference.

Changes to Impromptu Chart Formatting
Formatting charts in the Impromptu Series 7 Version 4 release has changed significantly from the 
last release. Powerful new dialogs have been introduced that offer more functionality. So, moving 
to the latest version of Impromptu means that you will not lose any functionality that you had in 
previous versions. However, it does mean that you will do certain tasks differently in the new 
environment. To identify the changes related to formatting charting, see the following topics:
• chart types 
• chart properties 
• titles 
• legends 
• data properties 
• grids, scales and axis labels 

Chart Types

See the following table to compare how you add and change the chart type in Impromptu Series 7 
Version 3 and Series 7 Version 4. 

Goal Series 7 Version 3 Series 7 Version 4

Add a 2D bar chart In the Chart Properties dialog, 
in the Chart type list, click 2D 
Bar.

In the Chart Properties dialog box, 
in the Chart type list, click Bar. On 
the Format tab, click Properties, 
and then on the General tab, 
un-check the Depth check box (no 
Depth).

Add a 3D bar chart.

Note: This 3D bar chart 
is not a true 
three-dimensional chart. 
It is a 2D bar chart with 
depth.

In the Chart Properties dialog, 
in the Chart type list, click 3D 
Bar.

In the Chart Properties dialog box, 
in the Chart type list, click Bar. On 
the Format tab, click Properties, 
and then on the General tab, specify 
Depth.

Add a pie chart. In the Chart Properties dialog, 
in the Chart type list, click 
either 2D Pie or 3D Pie.

In the Chart Properties dialog box, 
in the Chart type list, click Pie.

Add a 2D pie chart. In the Chart Properties dialog, 
in the Chart type list, click 2D 
Pie.

In the Chart Properties dialog box, 
in the Chart type list, click Pie. On 
the Layout tab, click 2D Circular 
Pie.
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Other Chart Properties

See the following table to compare how you change certain other chart properties in Impromptu 
Series 7 Version 3 and Series 7 Version 4.

Add a 3D pie chart. In the Chart Properties dialog, 
in the Chart type list, click 3D 
Pie.

In the Chart Properties dialog box, 
in the Chart type list, click Pie. On 
the Format tab, click Properties, 
and then on the General tab, specify 
Depth. 

Add a 2D area chart. In the Chart Properties dialog, 
in the Chart type list, click 2D 
Area.

In the Chart Properties dialog box, 
in the Chart type list, click Area. 
Click the Format tab, click 
Properties, and on the General tab, 
un-check the Depth check box (no 
Depth).

Add a 3D area chart.

Note: This 3D area chart 
is not a true 
three-dimensional chart. 
It is a 2D area chart with 
depth.

In the Chart Properties dialog, 
in the Chart type list, click 3D 
Area.

In the Chart Properties dialog box, 
in the Chart type list, click Area. 
Click the Format tab, click 
Properties, and on the General tab, 
specify Depth.

Add a line chart. In the Chart Properties dialog, 
in the Chart type list, click 
Line.

In the Chart Properties dialog box, 
in the Chart type list, click Line. 
Click the Format tab, click 
Properties, and on the General tab, 
un-check the Depth check box.

Add a 2D line. In the Chart Properties dialog, 
in the Chart type list, click 
Tape.

In the Chart Properties dialog box, 
in the Chart type list, click Line. 
Click the Format tab, click 
Properties, and on the General tab, 
specify Depth.

Add a log chart. In the Chart Properties dialog, 
in the Chart type list, click Log.

In the Chart Properties dialog box, 
in the Chart type list, click Line. 
Click the Format tab, click Grids 
and Scales, and then on the Scales 
tab, click Make Logarithmic. 

Add a tape chart. In the Chart Properties dialog, 
in the Chart type list, click 
Tape.

In the Chart Properties dialog box, 
in the Chart type list, click Line. 
Click the Format tab, click 
Properties, and on the General tab, 
specify Depth.

Goal Series 7 Version 3 Series 7 Version 4

Goal Series 7 Version 3 Series 7 Version 4

Change chart background, 
plot and legend color.

On the Format tab, in the 
Select box, click the chart. 
Under the Background color 
option, click Customize.

The color you specify 
applies to the chart, plot and 
legend areas.

On the Format tab, in the Chart 
background box, click the area of 
the chart to format: chart, plot or 
legend. Click Edit and use the 
Formatting dialog box to format the 
color.
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Titles

See the following table to compare how you change chart titles in Impromptu Series 7 Version 3 
and Series 7 Version 4.

Legends

See the following table to compare how you add and format a legend in Impromptu Series 7 
Version 3 and Series 7 Version 4.

Show chart values as a 
percent.

On the Format tab, click 
Percent.

On the Format tab, click Properties. 
On the Layout tab, click Percent.

Swap the chart axes. On the Format tab, click 
Swap.

On the Format tab, click Properties. 
On the Layout tab, select the 
Horizontal check box.

For pie chart, specify a 
pullout slice.

On the Format tab, in the 
Select box, click the chart. 
Click Show pullout slice. 
Use the dropdown list to 
specify the data item to pull 
out.

On the Format tab, click Properties, 
and on the General tab, specify an 
Explode value. This value is applied 
to each piece of the pie. To 
customize the Explode value for a 
particular slice, on the Format tab, 
click Customize per Data Item.

Goal Series 7 Version 3 Series 7 Version 4

Goal Series 7 Version 3 Series 7 Version 4

Add a chart title. In the Chart Properties 
dialog box, on the Format 
tab, click Chart Title.

In the Chart Properties dialog box, 
click the Format tab, and then click 
Titles.   Click the Title check box 
and type a title.

Add a primary or x-axis 
title.

On the Format tab, click the 
primary or x-axis Title.

In the Chart Properties dialog box, 
click the Format tab, and then click 
Titles.   Click the Category Title 
check box and type a x-axis title.

Add a secondary or y-axis 
title.

On the Format tab, click the 
secondary or y-axis Title.

In the Chart Properties dialog box, 
click the Format tab, and then click 
Titles.   Click the Value Title (Y1) 
check box and type a y-axis title.

Format a title. On the Format tab, in the 
Select box, click the chart or 
axis title, then click Font. 
Use the Chart Font dialog 
box to format the title.

In the Chart Properties dialog box, 
on the Format tab, use the Font 
formatting list box to select the title, 
then click Edit.

Goal Series 7 Version 3 Series 7 Version 4

Add a legend. In the Chart Properties 
dialog box, on the Format 
tab, click Legend, and then 
click Show the legend.

In the Chart Properties dialog box, 
on the Format tab, click Properties. 
Click the Look tab, and select Show 
Legend.
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Data Properties

See the following table to compare how you change data properties in Impromptu Series 7 Version 
3 and Series 7 Version 4.

Change legend and legend 
marker location.

On the Format tab, click 
Legend, with Show the 
legend selected, specify the 
legend location and the 
location of markers and 
legend text. 

In the Chart Properties dialog box, 
on the Format tab, click Properties. 
Click the Look tab, select Show 
Legend, and specify the legend 
options.

Format legend text. In the Chart Properties 
dialog box, on the Format 
tab, click Legend, then click 
Font. Use the Chart Font 
dialog box to format the 
legend text.

In the Chart Properties dialog box, 
on the Format tab, use the Font 
formatting list box to select the title, 
then click Edit.

Goal Series 7 Version 3 Series 7 Version 4

Goal Series 7 Version 3 Series 7 Version 4

Plot null data. On the Format tab, in the 
Null data box, click Plot as 
zero or Exclude from chart. 

Available only for line 
charts.

In the Chart Properties dialog box, 
on the Data tab, select the Plot null 
data check box. 

Available only for line and 
correlation charts.

For bar charts only, change 
the location of data labels.

On the Format tab, in the 
Select box, click the chart. In 
the Display options box, in 
the Show Values box, click 
where you want the data 
labels to appear.

In the Chart Properties dialog box, 
on the Format tab, click Properties. 
Click the Data Labels tab, select 
Show Data Labels, and then specify 
Labels Location and Label Format. 

Per data item, customize

data item color

marker style

marker size

line style

On the Format tab, in the 
Select box, click the chart. 
Click Customize per Data 
Item.

In the Chart Properties dialog box, 
on the Format tab, click Customize 
per Data Item.

For the entire chart or series, 
specify line style, marker 
style and size.

This applies to line, bubble 
and scatter charts.

On the Format tab, click the 
chart. In the Display options 
box, specify line style, 
marker style and size.

To format marker shape and size:
On the Format tab, click Properties 
and use the General tab.

To format the line style:
On the Format tab, click Customize 
per Data Item and specify the line 
style for each data item.
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Grids, Scales and Axis Labels

See the following table to compare how you add and format grids and scales in Impromptu Series 
7 Version 3 and Series 7 Version 4.

Show data items with color. On the Format tab, click the 
chart. In the Display options 
box, in the Data item colors 
box, click Show as colors. 
Data items automatically 
appear in different colors.

After you specify color to 
show, to customize the color 
of each data item, click 
Customize per Data Item. 

On the Format tab, click Customize 
per Data Item and the color of a 
data item. In the Formatting dialog, 
specify a color from the color 
palette.

Show data items with 
pattern.

On the Format tab, click the 
chart. In the Display options 
box, in the Data item colors 
box, click Show as patterns. 

After you specify pattern, to 
customize the pattern for 
each data item, click 
Customize per Data Item.

On the Format tab, click Customize 
per Data Item and in the Color 
column, click the color for a data 
item. In the Formatting dialog box, 
in the Fill Options, click Pattern. In 
the Choose a Pattern dialog box, 
specify the fill pattern, foreground 
and background color. 

Goal Series 7 Version 3 Series 7 Version 4

Goal Series 7 Version 3 Series 7 Version 4

Add gridlines. On the Format tab, in the 
Select box, click the chart. 
Select the Primary gridline 
check box to gridlines to the 
x-axis. Select the Secondary 
gridline check box to add 
gridlines to the y-axis.

On the Format tab, click Grids and 
Scales. Click the axis tab, and then 
click the Grids tab. You can specify 
gridlines, grid style and grid spacing 
for major and minor gridlines.

Add and format x-axis 
labels.

On the Format tab, in the 
Select box, click the Labels 
button for the x-axis. Select 
Show the labels check box 
to add the axis labels.

Click Font to format the 
labels.

To add labels:
On the Format tab, click Grids and 
Scales. Click the Category Axis, and 
use the Labels tab and General tab 
to add labels and specify how they 
display.

To format labels:
On the Format tab, in the Font 
formatting list, click the axis you 
want to format, for example, 
Category axis, and then click Edit. 

Wrap x-axis labels. On the Format tab, in the 
Select box, click the Labels 
button for the x-axis. Select 
Show the labels check box 
to add the axis labels.

Click Word wrap to wrap 
labels.

Word wrap text:
You cannot specify word wrap 
explicitly. Text is wrapped 
automatically. 

For information on formatting 
x-axis labels, see "Add and format 
x-axis labels". 
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For more information, see the section  "Impromptu Chart Changes" in the Impromptu 
Administration Guide and Impromptu User Reference. 

Impromptu Web Reports

Changes to Behavior of Browser Back Button When Viewing Reports
When you click the Back button, you now return to the page from which the report was launched. 
Depending on the type of report, such as a prompt or a drill-through report, the launch page can 
be any of the following: 
• the Upfront NewsBox that contains the report
• the Actions page from which the report was run
• the Run Options page
• the last prompt page
• the last drill-through selection page

Previously, the Back button returned you to the running report page.

In addition to the Back button, you can still use the following Cognos navigation buttons from the 
report output page:
• previous report button - after a drill through, this button returns you to the previous report 

output, regardless of whether there were intermediate prompts or multiple drill links choices 
• return to source button - from all report output pages, this button returns you to the 

NewsBox for the report.

Changes to start-iwr Script
On UNIX, when you use the start-iwr script to start the Impromptu Web Reports services, control 
is now returned to the calling process only after all Impromptu Web Reports services have started.

Truncated x-axis labels. On the Format tab, in the 
Select box, click the Labels 
button for the x-axis. Select 
Show the labels check box 
to add the axis labels.

Click Truncate to truncate 
labels.

Truncate text:
You cannot specify that text be 
truncated explicitly. It is truncated 
automatically.

For information on formatting 
x-axis labels, see  "Add and format 
x-axis labels".

Add and format y-axis 
labels.

On the Format tab, in the 
Select box, click the Labels 
button for the y-axis. Select 
the Show labels check box 
to add the axis labels.

Select Customize the scale 
and then edit the Minimum, 
Maximum and Number of 
steps boxes to customize the 
labels.

To add labels:
On the Format tab, click Grids and 
Scales. Click the a y-axis tab, and 
use the Labels tab and General tab 
to add labels and specify how they 
display.

Goal Series 7 Version 3 Series 7 Version 4
40  Cognos Series 7 Version 4    



 Appendix A: Feature Changes
 

PowerPlay

Changes to Enable Creating PowerPlay Agents in a New Browser Window
To improve the ease of use for creating alerts, you can now choose to open the Agent wizard in a 
new browser window. This enables you to more easily refer back to the original PowerPlay report 
as you are entering agent details such as conditions or the description.

Changes to Formatting When Exporting to Excel
When you export reports to Excel with PowerPlay for Series 7 Version 4, some numeric 
formatting is changed that was previously preserved when exporting using PowerPlay for Series 7 
Version 3. If you have data that uses the K or M notation to denote numbers in the thousands and 
millions, respectively, that notation is stripped out during the export using PowerPlay for Series 7 
Version 4. Also, if you have other display formatting, such as one that makes values appear to be 
rounded, this will also be removed. However, currency notation is maintained.

For example, a value of $23K is exported as $23,225.00.

This is consistent with the behavior for exporting to Excel using PowerPlay Web in Series 7 
Version 4.

Changes to Excel Export Support
PowerPlay for Series 7 Version 4 now supports exporting to Excel so that layers in a report can be 
exported to separate worksheets in Excel (p. 24). This means that Excel 2002 or higher is the 
supported version of Excel, by default. 

You can change this default using Configuration Manager if you need to use an older version of 
Excel. Note that you will not be able to export layers to separate worksheets if you configure 
PowerPlay to use a version earlier than 2002. 

Alternatively, you can configure the export feature to always export all layers to a single sheet. Use 
the Excel Export for Layered Report setting in Configuration Manager.

For more information, see the General Properties section of the topic "PowerPlay Settings" in the 
Configuration Manager User Guide.

Changes to Configuration Manager Setting to Control Memory
The PowerPlay Client displays this message when you request a report whose results exceed the 
available memory. 
"This action will exceed your available system resources. This action has been 
cancelled."

If this occurs, PowerPlay will cancel the operation and the data is rolled back to the last state 
before the limit was exceeded. 

The PowerPlay limit for the number of categories is approximately 4,000,000, but this depends 
also on the memory capacity of your computer. Particularly in reporter reports, multiple actions 
are saved for the Undo function, and therefore less memory is available for categories and nesting.

You can use Configuration Manager to increase the Maximum Axis Size setting, and request the 
report again. The Maximum Axis Size setting limits the number of elements, such as rows, 
columns, and layers, that can exist on the axis. It is set to 2,000,000 by default.

If the Maximum Axis Size value is set to zero, the product will not check the memory limit prior 
to the task and therefore will show the following error message and exit if sufficient memory is 
not available to complete the task:
"PowerPlay resource limit reached. The application must close."

If this situation occurs often, we recommend that you redesign your models or cubes to avoid such 
large categories.
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For more information, see "General Properties" in the "Cognos PowerPlay Settings" section of 
the Configuration Manager User Guide, or contact your administrator.

Changes to Dynamic Custom Exception Highlighting
When a cube is rebuilt with new data, the custom exception highlighting you defined in 
PowerPlay Windows and PowerPlay Web Viewer will highlight exceptions found in the new data, 
as well as those already highlighted in the previous data. Reports published to Upfront with 
custom exceptions are also updated with the new data the next time they are run. 

Cognos Visualizer

Changes to Scene Control in the Web Viewer
You can now maximize scenes on a sheet in the Web Viewer. This is the same capability available 
in the Java Web Client.

Changes to Drilling On Alternate Drill Paths
You can drill up and down on both primary and alternate drill paths. 

Previously, you could only drill up through the primary path, even if you drilled down on an 
alternate path.

Changes to Filter Settings on Chart Axes, Legends and Maps
When you exclude a category using the radio, check, range or animation filter, Visualizer chart 
axes and legends will no longer include these categories. This is consistent with the new behavior 
of zero suppression on dimensional sources, in which categories that are suppressed by the 
visualization author do not appear on chart axes or legends. Calculated items, such as a 
maximum, will also exclude values that are filtered out or suppressed. 

When you use a filter to exclude a category for a location on a map, the behavior of the filtered 
map location depends on the setting called Display Locations with No Data. If this option is not 
selected, the map location will disappear. If the option is selected, the map location appears, using 
the associated No Data color.

This change applies to Visualizer authoring, the Web Client, and the Viewer.

Previously, legends and charts showed entries for categories that were filtered out. If you were not 
aware that a filter was enabled you might have concluded that the data value was zero for filtered 
out categories.

Changes to Error Logging
You can enable improved error logging on each Cognos Visualizer Web Edition server to capture 
error information in the vizweberror.log file. Error information is also sent to the Event Viewer in 
Windows. The error settings now apply to all visualizations published to a Visualizer server.

In previous releases, error information was sent to the vizweb.log file along with audit and system 
information, which meant that you had to review all of the logged information to find error 
messages. Now a tab-delimited error log file called vizweberror.log is created in the 
<installation_location>\cern\logs location.

For more information, see the Cognos Visualizer Administrator’s Guide. 
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Appendix B: New Features for Series 7 Version 3 
MR1, MR2, and MR3

Depending on which release of Series 7 Version 3 you may have installed, you may not be aware 
of features introduced in the following maintenance releases: 
• Series 7 Version 3 MR1 (p. 43)
• Series 7 Version 3 MR2 (p. 47) 
• Series 7 Version 2 MR3 (p. 50) 

These features are also included in Series 7 Version 4.

Series 7 Version 3 MR1 New Features 

Installation and Configuration

Using an Alternate Logon Gateway

To improve Web server performance, you can configure Access Manager logon to use an alternate 
gateway that replaces the default CGI program.

The alternate gateways available are native server extensions for ISAPI to support Microsoft 
Internet Information Server on Windows, for NSAPI to support Sun Java System Web servers on 
both Windows and UNIX, and for the Apache module. 

For more information, see the Configuration Manager User Guide.

Implementing Faster Visualizer Failover

To improve performance, and provide dispatcher failover support in a single gateway and multiple 
dispatcher environment, new properties were added to the Cognos Visualizer Web Server 
Gateway. You can configure them using Configuration Manager.

Specifically, you can now set Gateway Timeout, Connect Retry, and Connect Timeout values in a 
new Tuning properties section. 

For more information, see the Configuration Manager User Guide.

Supported Environments
For information about supported software environments, see the Cognos Global Customer 
Services Web site (http://support.cognos.com).

Complying with New IE6 SP2 Browser Security Measures

HTML-based online help for Cognos Series 7 Version 3 MR1 products now complies with 
security measures that Microsoft implemented for Internet Explorer (IE6 SP2) and Windows XP 
SP2.

Help buttons that previously linked to an HTML file through a local file path now link to the 
same file through a Web alias, such as http://computer_name/cognos/help. Because of this change, 
the warning message from Microsoft Internet Explorer about active content being blocked no 
longer appears.
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Support for AIX 5.3

AIX 5.3 is a supported operating system for Cognos Series 7 Version 3 MR1.

If you are upgrading from Cognos Series 7 Version 2 or earlier to Cognos Series 7 Version 3 MR1, 
follow the upgrade instructions in the Cognos Series 7 Version 3 for UNIX Installation Guide. 

If you have an existing Impromptu Web Reports 7.3 installation and are upgrading to AIX 5.3, 
you must also upgrade to Impromptu Web Reports 7.3 MR1, including an upgrade to the new 
version of ObjectStore, version 6.1 SP2. 

Support for IBM Tivoli Directory Server

IBM Tivoli Directory Server is now supported.

For more information, see the Configuration Manager User Guide.

Support for Netscape 7.2 Browser

Netscape Version 7.2 is now supported.

Improved Scalability and Performance

Reducing Browser Requests When Viewing PDF-based Reports

In previous releases, viewing PDF-based reports in Microsoft Internet Explorer generated excess 
data traffic when opened from PowerPlay Enterprise Server or Impromptu Web Reports. The 
problem was related to unnecessary GET requests generated by Microsoft Internet Explorer, by 
default, when processing PDFs.

Now only one GET request is used to retrieve the contents of each PDF report. Users may see an 
improvement in performance.

Access Manager

Support for External Users Defined in a Remote Directory Server

In previous releases, external user support was limited to linking to users defined outside the 
Cognos namespace but within the same local directory server as the Cognos namespace.

You can now use Access Manager administration to link to a list of users that are defined in a 
remote (secondary) directory server, such as your corporate directory server. The local directory 
server that contains the Cognos namespace must be one of the directory servers listed on the 
Cognos Global Customer Services Web site (http://support.cognos.com). However, your 
secondary directory server can be any LDAP v3-compliant directory server. 

After your users are linked to one or more namespaces, changes made to these users in the 
secondary directory server are automatically reflected in Access Manager. This eliminates the need 
to duplicate or synchronize user attributes between the Cognos namespace and your corporate 
directory server.

Enable external user support if all the users who will access the Cognos namespace are already 
defined and maintained in another directory server. Because external user support is not 
backwards compatible, enable this feature only if all applications accessing the Cognos namespace 
use Series 7 Version 3 MR1 or later.

For more information, see the Access Manager Administrator Guide.

Impromptu

Handling Locale-Specific Date Formatting in Impromptu

The way Impromptu handles General formatting and pick list prompts for Date, DateTime, and 
Time data types is improved. Localized short and long names for days and months are also 
improved. Both improvements are based on retrieving information from the cerlocale.xml file.
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These two changes are designed to ensure consistency regardless of the implementation scenario. 
They do not require intervention by the user, or an upgrade of existing reports. 

For information about using the cerlocale.xml file to customize data formats for a particular 
locale, see the data formats and locale setting section of the Impromptu online help. 

For general information about locale-related formatting in the other components, see the 
Configuration Manager User Guide.

Use Database Stored Procedures in PowerPrompts

Prompt pages created for PowerPrompts applications can call stored procedures in a supported 
database using JavaScript or dynamos.

For more information, see "Use Database Stored Procedures" in PowerPrompts Reference.

Default to the Current Date in Type-in Impromptu Prompts 

The default date for type-in prompts can be set at run-time to the current date and time in the 
user’s locale.

For more information, see "Creating Prompts Using the Prompt Manager" in Mastering 
Impromptu Reports.

Sort Returned Values in Impromptu Selection Lists

When selecting values in a report filter or catalog condition, Impromptu users can specify either 
an ascending or descending sort. This is an alternative to viewing the values in the default sort 
order set by the database.

For more information, see "Sort Returned Values in Impromptu Selection Lists" in Mastering 
Impromptu Reports.

Impromptu Web Reports

Sort Impromptu Report Versions by Date and Time

Users can now sort report versions in Impromptu Web Reports by their creation date and time. 
Descending (most recent report versions appear first) is the default sort order. However, users can 
change this to ascending order on both the Select Versions and Delete Versions pages. 

For more information, see "Maintain Report Versions" in the Cognos Web Portal User Guide.

PowerPlay

Improved Integration of PowerPlay and Cognos ReportNet

You can use the PowerPlay Enterprise Server Administration tool to:
• select the Publish-to-ReportNet cube and report folders using a tree view
• set up drill-through access to targets in a selected ReportNet folder

For more information, see the PowerPlay Enterprise Server Guide.

Moving PowerPlay NewsItems from Upfront to Cognos ReportNet

To improve the integration of Cognos Series 7 and ReportNet, you can use a command-line tool 
to move PowerPlay cube and report NewsItems from Upfront to ReportNet.

This makes it easier to deliver existing PowerPlay cubes and reports using ReportNet. You do not 
have to republish cubes and reports to deliver the content through Cognos Connection.

After you move the PowerPlay NewsItems, you can reduce report administration requirements by 
configuring your environment to make Cognos Connection the default portal for both PowerPlay 
and ReportNet.

For more information, see the PowerPlay Enterprise Server Guide and the PowerPlay Macro 
Reference Guide.
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Controlling Read Cache Size on a Cube-by-Cube Basis

Using the PowerPlay Enterprise Server Administration tool, you can specify read cache size on a 
cube-by-cube basis. This means that you can improve the performance and overall scalability of 
PowerPlay implementations.

For more information, see the PowerPlay Enterprise Server Guide.

Counting Categories When Using Time-based Partitioned Cubes

Category count was added to the list of measures supported for time-based partitioned cubes. This 
means that analysts can see these counts in their PowerPlay reports, whether or not the cubes are 
time-based partitioned cubes.

However, some limitations still apply, whether you are using category count in regular or 
time-based partitioned cubes. The Activity Measure for a category count rollup cannot be one of 
the following:
• a category count measure
• an externally rolled-up measure
• a calculated after-rollup measure
• an allocated measure. An exception is when the measure is allocated only in dimensions other 

than the category count dimension or is allocated at or below the counted level of the category 
count dimension.

As with previous releases, the counted level must appear in the primary drill-down path of the 
category count dimension, and must be unique. If the Transformer model is set up to use one of 
the measure types not supported for category count, an error message appears.

Cube modelers must explicitly set a supported Activity Measure on the Rollup tab of the Measure 
property sheet. If this setting is left at its default (All Measures in the cube), at run-time, some 
measures are disregarded and the count does not accurately reflect all categories with non-zero 
values. 

For more information, see the PowerPlay Web User Guide.

Creating Custom Subsets with Top and Bottom Categories

Use the Custom Subset wizard in PowerPlay Web Explorer to create custom subsets that include 
categories having either the highest or lowest values of a specific measure.

Users can dynamically select the number of categories to include in the subset, such as the top ten 
or the bottom 25.

For more information, see the PowerPlay Web User Guide.

Description of Custom Subset Definitions

If a dimension filter or a crosstab row or column contains a custom subset, the Explain window in 
PowerPlay Web Explorer shows a concise description of the custom subset definition, next to an 
identifiable icon.

For example, instead of just the subset name, subset categories are listed in the form of searchable 
strings, ranges, or contains expressions. Starting points and scope may also be shown.

The detailed text can be viewed and modified in the Custom Subset wizard. 

For more information, see the PowerPlay Web User Guide.

Visualizer

Representing Missing Values Consistently in Visualizer

Visualizations and charts now show missing measure values as defined for each cube in 
Transformer, the modeling component of PowerPlay. This means that they now appear as zeros or 
as N/A (Not Applicable).
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Authors can prevent zeros from unintentionally skewing their statistical calculations by asking 
PowerCube modelers to explicitly choose the N/A option. By default, Transformer replaces 
missing values with zero.

In the case of CSV data sources imported directly into Visualizer without passing through a 
Transformer PowerCube, there is no change to the previous behavior: Visualizer respects the CSV 
treatment of the missing values.

Affected outputs include pie, line, multi-line, map, gauge, parallel, swatch, value, table, and 
crosstab charts. Waterline calculations, which can be based on means with or without standard 
deviations, are also affected. 

Trend charts are unaffected because they use measures for comparison purposes, not display. 
Statistical charts such as Control Limits, Histogram, Normal Curve, or Box and Whisker are not 
affected because they are not based on PowerCubes.

For more information, see the Cognos Visualizer User Guide.

Series 7 Version 3 MR2 New Features 

Supported Environments
For information about supported software environments, see the Cognos Global Customer 
Services Web site (http://support.cognos.com).

Support for Windows 2003 Active Directory Application Mode

Microsoft Active Directory Application Mode (ADAM) is now supported.

Support for Apache Mod 2.0 With SSL

Apache Mod 2.0 with SSL is now supported.

Support for Firefox 1.0 Browser

Firefox 1.0 is now supported.

Access Manager

Improved Flexibility for Web Single Signon

In previous releases, operating system signons in Web deployments were validated against the 
contents of a CGI environment variable named REMOTE_USER. You can now use other 
variables or cookies to obtain signon information.

For more information, see the Access Manager Administrator Guide.

Checking Namespace Integrity

In certain cases, such as an unexpected hardware failure, a namespace can become corrupted. If 
this occurs, unexpected behavior can result.

You can test your namespaces to determine whether they have become corrupted by using a 
command line tool. If your namespace has become corrupted, you should contact customer 
support to correct the problem.

For more information, see the Access Manager Administrator Guide.

Namespace Reporting for User Passwords

New reporting options have been added that list users with expired passwords and to indicate 
when a user's password was changed. 
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You use the AM_NamespaceReport command line utility to create an XML report that lists all 
users or user classes in a namespace. New output options have been added to show expired 
passwords and when a user last changed their password.

For more information, see the Access Manager Administrator Guide.

Improved Namespace Auditing

The Audit Logging function included with the Access Manager Trusted Services Plug-in Software 
Development Kit has been enhanced to generate log entries for changes to access to data source 
connections and changes to data source signons. 

For more information, see the Access Manager Trusted Services Plug-in SDK Guide.

Impromptu

Controlling the Size of Impromptu Reports Definitions

A Report Defrag Threshold option has been added to let you manage the size of Impromptu 
report definitions.

For more information, see "Manage the Size of Impromptu Reports" in the Impromptu 
Administration Guide and Mastering Impromptu Reports.

Impromptu Web Reports

Automating Audit and Clean Up Tasks for Impromptu Web Reports

Auditing and cleanup operations have been added for Impromptu Web Reports. SetAuditSchedule 
lets you modify the schedule for audit data collections. SetCleanupSchedule lets you modify the 
schedule for system cleanup tasks.

For more information, see "Schedules" in the Impromptu Web Reports Administrator Guide.

Tuning Properties for Impromptu Web Reports Systems

Three properties have been added to let you better manage Impromptu Web Reports systems that 
service a large number of users. The properties are:
• Keep Alive After Request Manager Requests
• Maximum Request Manager Read Timeout
• Maximum Client Wait Timeout

For more information, see the "Cognos Impromptu Web Reports Settings" chapter in the 
Configuration Manager User Guide.

PowerPlay 

Republishing PowerPlay Reports to Upfront

The RepublishToUpfront macro has been enhanced so that you can republish reports without 
being required to have the reports open in PowerPlay for Windows, and to republish more than 
one report at a time.

For more information, see the PowerPlay Macro Reference Guide.

PowerPlay Web

Changes to Percent of Base Calculation in PowerPlay Web

The Percent of Base calculation in PowerPlay Web has been enhanced to allow you to select a 
category to be used as the base value. You can also specify whether subtotals are to be used as 
base values.
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For more information, see the PowerPlay Web User Guide.

Copying Charts from PowerPlay Web

Charts displayed in PowerPlay Web views can be copied and pasted into other applications, such 
as Microsoft PowerPoint presentations or Microsoft Word documents.

You can only copy charts if you are using PowerPlay Web in Microsoft Internet Explorer.

For more information, see the PowerPlay Web User Guide.

Copying and Modifying Custom Subsets

With this release you have more features available to manipulate your custom subsets, including 
the ability to:
• copy subsets to make additional subsets
• reorder categories in the create custom subset wizard
• add, remove, and reorder categories in a subset by using drag and drop if you use Microsoft 

Internet Explorer

For more information, see the PowerPlay Web User Guide.

PowerPlay Web Integration with Microsoft Excel

Cognos Office Connection enables integration between PowerPlay Web content and Microsoft 
Excel. Cognos Office Connection works with PowerPlay cubes and reports that have been 
published to the Cognos Connection portal.

Cognos Office Connection is a new product available online from the Cognos Web site 
(http://www.cognos.com) or the Cognos Global Customer Services Web site 
(http://support.cognos.com).

Transformer

Controlling Whether Constantly Allocated Values are Rolled Up

You can control whether constantly allocated values are rolled up for queries that are based on 
rollup groups, custom subsets, custom filters in Visualizer, and alternate or special drill-down 
paths. 

Some constantly allocated values are rolled up in PowerPlay and Visualizer. For example, in 
PowerPlay Web, the total of the values in a custom subset of constantly allocated values is the sum 
of the constantly allocated values. You can change this so that the total is the same constantly 
allocated value as is shown for each individual member of the subset. 

For more information, see note and the Related Topics linked in the topic  "Allocate Measures: 
Overview" in Step-by-Step Transformer.

Using Large Numbers of User Classes in Transformer Modeling

Transformer includes a new User Class Browser that lets you select the user classes that you want 
to include in your model.

In previous releases, Transformer loaded all user classes at once. In this release, you can select the 
user classes that you want to include in the model before they are loaded using the User Class 
Browser.

For more information, see the topic "Enable User Security for a Model" in Step-by-Step 
Transformer.
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Series 7 Version 3 MR3 New Features 

Impromptu

Additional Excel Export Settings in Impromptu

Just like the inclusion of images, static charts, text frames and summary expressions can be 
controlled when exporting to Excel 2002 or higher, users can now also control grouped data and 
summary rows from list frames. This makes it easier to use Excel features such as PivotTables and 
AutoFilters, because you can select to suppress summary rows and not suppress detail rows within 
grouped data. This also makes it easier to export to other formats, such as Microsoft Access.

These Impromptu settings do not affect how the report appears in a PDF, allowing the PDF to 
conserve its group summary rows and to suppress grouped data items to make it easier to read. 
These settings also control the export when it is done from Impromptu Web Reports.

For more information, see the Impromptu User Reference online help. To view the help topic, 
click the Help button in the Report Properties dialog box, Excel tab. 

More Secure PowerPrompts JavaScript Client Variable Input Methods

Two new methods have been added to PowerPrompts in order to increase security when using 
prompts for users to input variables. When these methods are used, prompt inputs are verified to 
ensure that they contain a valid number or string. These two methods are:

GetUserVarAsSafeNum
GetUserVarAsSafeString

For more information, see "JavaScript Client Methods" in the PowerPrompts Reference Help.

PowerPlay

Integration of PowerPlay and Cognos 8

All the integration points that are supported between PowerPlay and Cognos ReportNet are now 
also supported for Cognos 8. You can publish PowerPlay reports to the Cognos 8 portal, and set 
up drill-through access to targets in Cognos 8. 

To use these integration points, follow the same instructions to publish or drill-through to Cognos 
ReportNet. The server properties in the PowerPlay Enterprise Server Administration tool are valid 
for Cognos ReportNet as well as for Cognos 8.

For more information, see the PowerPlay User Guide.

Note: If you are upgrading from Cognos ReportNet to Cognos 8, you must either restructure your 
virtual directories so that the Series 7 and Cognos 8 gateways are within the same structure, or 
change the default cookie path in Cognos 8. 

For more information, see the Configuration Manager User Guide.
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